Monday, 7 May 2018

ソースコード読み会

今年は、5/25-5/27 にしようかと思ってます。新歓と重なってるらしいが、昼間は空いてるんだろ?

今年も、x.v6 かも。まだ、読んでないところ結構あるし。でも、今日は、

  Ruby on Rails

なんですが、pry なるものがあるらしい。「じゃぁ、使ってみせて」 Rails の shell みたいなものらしいです。一応、

  Controller を trace できる

のだが... 「ちょっと、待て、読もうとしているのは、Rails であって、その上の Application じゃないだろ? 」結局、Rails 自体の trace には使えないらしい。

普通に、ruby -r debug rails なんじゃないかな。と思ったら、

  requires ruby 2.4

あ、そうですか。gem で取ってくるのではなくて、source は直接取ってきたのだな。最新は ruby 2.5.1? じゃぁ、それを入れ替えてからだな。

昔は、Perlの新しい版にワクワクしたものですけどね。今は「また、新しい版? どうせ、どこか動かなくなるんだろ? 」ってなところですね。
Post a Comment